Kho cho người dùng ArchLinux

Thẻ: ,
Bài mẹ: /doc/buildsystem

Để sử dụng các gói của TheSLinux trên ArchLinux, bạn có thể dùng kho chính thức các gói như sau đây.

  1. Tải các gói cơ bản
  2. Cài đặt gói mới tải về
  3. Điều chỉnh /etc/pacman.conf
  4. Cập nhật pacman
  5. Lưu ý quan trọng

Tải các gói cơ bản

Tải về hai tập tin theslinux-keyringtheslinux-keyring.sig từ địa chỉ

http://f.theslinux.org/theslinux/p/t/theslinux-keyring/

Dùng gpg để kiểm tra rằng tập tin tải về là hợp lệ

$ gpg --recv-keys 503CDEA5

gpg: requesting key 503CDEA5 from hkp server keys.gnupg.net
gpg: key 503CDEA5: public key "Anh K. Huynh <[email protected]>" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)

$ gpg --verify theslinux-keyring-latest-any.pkg.tar.xz.sig

gpg: Signature made Fri Nov 28 15:03:05 2014 ICT using RSA key ID 503CDEA5
gpg: Good signature from "Anh K. Huynh <[email protected]>" [unknown]
gpg:                 aka "TheSLinux-Security <[email protected]>" [unknown]
gpg: WARNING: This key is not certified with a trusted signature!
gpg:          There is no indication that the signature belongs to the owner.
Primary key fingerprint: 1BD3 A113 475B 8735 D34E  9CC1 B477 86AF 503C DEA5

Dòng WARNING cuối cùng có thể bỏ qua.

Cài đặt gói mới tải về

Nếu không có lỗi gì, bạn có thể tiến hành cài đặt gói theslinux-keyring

$ rm -fv theslinux-keyring-latest-any.pkg.tar.xz.sig
$ pacman -U theslinux-keyring-latest-any.pkg.tar.xz

(Nếu gặp bất kỳ lỗi gì ở bước này, bạn phải dừng lại và tìm kiếm sự giúp đỡ từ cộng đồng. Phiên bản mới nhất của gpg có thể buộc bạn phải xóa đi /etc/pacman.d/gnupg và chạy lại pacman-key --init.)

Điều chỉnh /etc/pacman.conf

Thêm vào tập tin /etc/pacman.conf cấu hình sau

[theslinux]
SigLevel = Required DatabaseRequired
Server = http://f.theslinux.org/$repo/z/$arch/

Thứ tự rất quan trọng. Bạn nên để mục [theslinux] trong phần cuối cùng của tập tin /etc/pacman.conf. Xem thêm phần Lưu ý quan trọng cuối bài này.

Cập nhật pacman

Sau đó, tiến hành cập nhật cho hệ thống và tìm các gói của TheSLinux

$ pacman -Syy

....
theslinux         6.5 KiB  6.34M/s 00:00 [#####...] 100%
theslinux.sig   287.0   B  0.00B/s 00:00 [#####...] 100%

$ pacman -Ss uim-vi

theslinux/126-uim-vi 1.0.0-2
    Default profile for uim-vi
theslinux/uim-vi 1.8.6-2
    Vietnamese input method library
...

Nếu gặp trục trặc, vui lòng liên hệ các kênh hỗ trợ của #TheSLinux.

Lưu ý quan trọng

Do lỗi của pacman mà một số gói của TheSLinux với các ký tự đặc biệt trong tên như pacman%makepkg hay uim-vi%lib32 không thể cài được trên các máy ArchLinux thông thường.

Để cài các gói đó, bạn phải cài bằng tay, hoặc đặt [theslinux] trước mục [core] trong cấu hình /etc/pacman.conf. Cái giá phải trả là

  1. Bạn sẽ phải sử dụng gói pacman từ kho [theslinux], theo đó makepkg sẽ không chạy được theo cách thông thường; HOẶC
  2. Bạn sẽ phải bỏ qua gói pacman bằng cách thêm vào dòng IgnorePkg trong /etc/pacman.conf tên gói pacman.

Bạn đã được cảnh báo trước!

----
13 commit(s) 1 author(s);
last updated by Ky-Anh Huynh @ Tue Jun 9 19:44:04 2015 +0700

Trang này là một phần của TheSLinux,
 và được phân phối với giấy phép CC BY-SA 3.0.

Bạn được Sao chép, Chia sẻ, Phân phối trang này dưới điều kiện sau:

(1) Bạn phải ghi tên tác giả TheSLinux và giấy phép; tuy nhiên không
    được hàm ý tác giả trao trang này hay quyền sử dụng trang này cho bạn;
(2) Nếu bạn sử dụng, chuyển đổi, hoặc xây dựng dự án từ trang này,
    bạn phải áp dụng giấy phép BY-SA hoặc giấy phép có các điều khoản
    tương tự như giấy phép BY-SA cho dự án của bạn.